Plugin Uploadcare in TinyMCE 5

Hi,

I wish to know how can i integrate uploadcare plugin in the new version of TinyMCE (version 5) because in migrating version the plugin does not work now… ( I have this error message : "
Failed to initialize the module: uploadcare" ) in the inspector it marks : “uploadcare Error: editor.addButton has been removed in tinymce 5x, use editor.ui.registry.addButton or editor.ui.registry.addToggleButton or editor.ui.registry.addSplitButton instead” ! While it worked in the previous version (version 4).

Thanks you.

Hi @scanuremy

What version if uploadcare-tinymce are you using?

Having same issue using uploadcare-tinymce v3.1.0

@nd0ut can you take a look?

Thanks for the feedback!

We’re not support TinyMCE 5 yet.

There is an issue on gh where you can track the progress: Update for TinyMCE 5 · Issue #10 · uploadcare/uploadcare-tinymce · GitHub

Stay tuned.