Widget requirements

  • This documentation is for the version 3.3.0 of the widget. If you're looking for the widget v2 docs, check here.

jQuery

Our widget does not have any external dependencies except for jQuery. We provide two different versions of our widget: with built-in jQuery and without it. You can read more about installing those here.

For instance, when using the jQuery widget version, you could do that,

var $ = uploadcare.jQuery;
$('body').append('It works!');

Browsers

Our widget should perfectly work in a couple of last browser versions. That works for Internet Explorer, Edge, Firefox, Google Chrome, Safari, and Opera. The widget is likely to run well in older versions of major browser too, except for Internet Explorer < 10.

If you are looking to support older browsers including IE8, consider checking out Uploadcare Widget v2.

We’re always happy to help with code, integration, and other stuff. Search our site for more info or post your question in our Community Area.